summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDylan Baker <[email protected]>2017-10-16 17:12:52 -0700
committerDylan Baker <[email protected]>2017-10-26 11:30:56 -0700
commit191e785c8101233ecf018b6bd4f62f969352199a (patch)
tree3ac869ab35304db6a75db3fa8c3b0a2b68e17bdb /meson.build
parent8da36268d44a15ca8b02709089a26ac5e678b139 (diff)
meson: build r100 driver
build tested only Signed-off-by: Dylan Baker <[email protected]> Reviewed-by: Eric Anholt <[email protected]>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 3 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 2a89b6482f9..5ca5c64954a 100644
--- a/meson.build
+++ b/meson.build
@@ -87,12 +87,14 @@ endif
with_dri = false
with_dri_i915 = false
with_dri_i965 = false
+with_dri_r100 = false
with_dri_swrast = false
_drivers = get_option('dri-drivers')
if _drivers != ''
_split = _drivers.split(',')
with_dri_i915 = _split.contains('i915')
with_dri_i965 = _split.contains('i965')
+ with_dri_r100 = _split.contains('r100')
with_dri_swrast = _split.contains('swrast')
with_dri = true
endif
@@ -627,7 +629,7 @@ dep_libdrm_freedreno = []
if with_amd_vk or with_gallium_radeonsi
dep_libdrm_amdgpu = dependency('libdrm_amdgpu', version : '>= 2.4.85')
endif
-if with_gallium_radeonsi # older radeon too
+if with_gallium_radeonsi or with_dri_r100 # older radeon too
dep_libdrm_radeon = dependency('libdrm_radeon', version : '>= 2.4.71')
endif
if with_gallium_nouveau