summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorEric Anholt <[email protected]>2017-10-12 18:39:08 -0700
committerEric Anholt <[email protected]>2017-10-17 13:41:59 -0700
commit1918c9b1627d5403e2efbffa03441c4b7d61a63e (patch)
tree780c115b218f47fd4b39d065036e698b53f9c080 /meson.build
parent1ae8018a6af81eec4832a57d9d0346aa3dd98d28 (diff)
meson: Add support for the pl111 driver.
Reviewed-by: Dylan Baker <[email protected]>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index f538cf79bb4..9967df08e01 100644
--- a/meson.build
+++ b/meson.build
@@ -91,6 +91,7 @@ if _drivers != ''
endif
with_gallium = false
+with_gallium_pl111 = false
with_gallium_radeonsi = false
with_gallium_nouveau = false
with_gallium_softpipe = false
@@ -98,6 +99,7 @@ with_gallium_vc4 = false
_drivers = get_option('gallium-drivers')
if _drivers != ''
_split = _drivers.split(',')
+ with_gallium_vc4 = _split.contains('pl111')
with_gallium_radeonsi = _split.contains('radeonsi')
with_gallium_nouveau = _split.contains('nouveau')
with_gallium_softpipe = _split.contains('swrast')