summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorGuido Günther <[email protected]>2018-08-26 22:23:59 +0200
committerDylan Baker <[email protected]>2018-08-27 11:31:52 -0700
commit05e2fc6860c515073a5cd7ed305dae86fc9c8232 (patch)
treef79eb3181686dab0ba38bda7c740435a65c779b4 /meson.build
parenta1e3305f7538562e99b6bb80e9f84c4baa1c43ae (diff)
meson: Be a bit more helpful when arch or OS is unknown
V2: Add one missing @0@ Signed-off-by: Guido Günther <[email protected]> Reviewed-by: Dylan Baker <[email protected]>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build21
1 files changed, 14 insertions, 7 deletions
diff --git a/meson.build b/meson.build
index 1b3dfa221c9..c3a7e8cdd74 100644
--- a/meson.build
+++ b/meson.build
@@ -102,13 +102,15 @@ if _drivers.contains('auto')
elif ['arm', 'aarch64'].contains(host_machine.cpu_family())
_drivers = []
else
- error('Unknown architecture. Please pass -Ddri-drivers to set driver options. Patches gladly accepted to fix this.')
+ error('Unknown architecture @0@. Please pass -Ddri-drivers to set driver options. Patches gladly accepted to fix this.'.format(
+ host_machine.cpu_family()))
endif
elif ['darwin', 'windows', 'cygwin', 'haiku'].contains(host_machine.system())
# only swrast would make sense here, but gallium swrast is a much better default
_drivers = []
else
- error('Unknown OS. Please pass -Ddri-drivers to set driver options. Patches gladly accepted to fix this.')
+ error('Unknown OS @0@. Please pass -Ddri-drivers to set driver options. Patches gladly accepted to fix this.'.format(
+ host_machine.system()))
endif
endif
@@ -135,12 +137,14 @@ if _drivers.contains('auto')
'tegra', 'virgl', 'swrast',
]
else
- error('Unknown architecture. Please pass -Dgallium-drivers to set driver options. Patches gladly accepted to fix this.')
+ error('Unknown architecture @0@. Please pass -Dgallium-drivers to set driver options. Patches gladly accepted to fix this.'.format(
+ host_machine.cpu_family()))
endif
elif ['darwin', 'windows', 'cygwin', 'haiku'].contains(host_machine.system())
_drivers = ['swrast']
else
- error('Unknown OS. Please pass -Dgallium-drivers to set driver options. Patches gladly accepted to fix this.')
+ error('Unknown OS @0@. Please pass -Dgallium-drivers to set driver options. Patches gladly accepted to fix this.'.format(
+ host_machine.system()))
endif
endif
with_gallium_pl111 = _drivers.contains('pl111')
@@ -176,13 +180,15 @@ if _vulkan_drivers.contains('auto')
if host_machine.cpu_family().startswith('x86')
_vulkan_drivers = ['amd', 'intel']
else
- error('Unknown architecture. Please pass -Dvulkan-drivers to set driver options. Patches gladly accepted to fix this.')
+ error('Unknown architecture @0@. Please pass -Dvulkan-drivers to set driver options. Patches gladly accepted to fix this.'.format(
+ host_machine.cpu_family()))
endif
elif ['darwin', 'windows', 'cygwin', 'haiku'].contains(host_machine.system())
# No vulkan driver supports windows or macOS currently
_vulkan_drivers = []
else
- error('Unknown OS. Please pass -Dvulkan-drivers to set driver options. Patches gladly accepted to fix this.')
+ error('Unknown OS @0@. Please pass -Dvulkan-drivers to set driver options. Patches gladly accepted to fix this.'.format(
+ host_machine.system()))
endif
endif
@@ -230,7 +236,8 @@ if _platforms.contains('auto')
elif ['haiku'].contains(host_machine.system())
_platforms = ['haiku']
else
- error('Unknown OS. Please pass -Dplatforms to set platforms. Patches gladly accepted to fix this.')
+ error('Unknown OS @0@. Please pass -Dplatforms to set platforms. Patches gladly accepted to fix this.'.format(
+ host_machine.system()))
endif
endif