summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorGurkirpal Singh <[email protected]>2018-01-20 05:12:06 +0530
committerJulien Isorce <[email protected]>2018-03-06 13:07:03 +0000
commitbb5e27fab6087a5c1528a5faf507acce700e883c (patch)
tree8c0bff83d1c599b20d75a62b998255615ae435ea /meson.build
parente96e6f60f705c04a3d437eea9fe308826b494c67 (diff)
st/omx/bellagio: Rename st and target directories
v2: Refactor out screen functions to st/omx Allows to keep all the code under st/omx (st/omx/tizonia and st/omx/bellagio). Reverts targets/omx_bellagio to omx as additions to existing files is enough to compile for both bellagio and tizonia. * autotools changes: --enable-omx -> --enable-omx-bellagio * meson changes: -Dgallium-omx=false -> -Dgallium-omx=disabled -Dgallium-omx=true -> -Dgallium-omx=bellagio Acked-by: Leo Liu <[email protected]> Reviewed-by: Julien Isorce <[email protected]>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build19
1 files changed, 9 insertions, 10 deletions
diff --git a/meson.build b/meson.build
index bb6a835084f..9bb114056b1 100644
--- a/meson.build
+++ b/meson.build
@@ -464,29 +464,28 @@ endif
_omx = get_option('gallium-omx')
if not system_has_kms_drm
- if _omx == 'true'
+ if _omx != 'disabled'
error('OMX state tracker can only be built on unix-like OSes.')
else
- _omx = 'false'
+ _omx = 'disabled'
endif
elif not (with_platform_x11 or with_platform_drm)
- if _omx == 'true'
+ if _omx != 'disabled'
error('OMX state tracker requires X11 or drm platform support.')
else
- _omx = 'false'
+ _omx = 'disabled'
endif
elif not (with_gallium_r600 or with_gallium_radeonsi or with_gallium_nouveau)
- if _omx == 'true'
+ if _omx != 'disabled'
error('OMX state tracker requires at least one of the following gallium drivers: r600, radeonsi, nouveau.')
else
- _omx = 'false'
+ _omx = 'disabled'
endif
-elif _omx == 'auto'
- _omx = 'true'
endif
-with_gallium_omx = _omx == 'true'
+with_gallium_omx = _omx != 'disabled'
+gallium_omx = _omx
dep_omx = []
-if with_gallium_omx
+if gallium_omx == 'bellagio'
dep_omx = dependency('libomxil-bellagio')
endif