summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorRob Herring <[email protected]>2019-01-23 16:08:08 -0600
committerRob Herring <[email protected]>2019-01-28 11:45:43 -0600
commit827e0d6654a2dba0c2090abde84ccef8c8d8ec7e (patch)
tree195d0827403f9833dae0c68a14c4f25e65dd4a60 /meson.build
parent272b6cf58f507180b2ff3059bec16d8f023f5f40 (diff)
kmsro: Add etnaviv renderonly support
Enable using etnaviv for KMS renderonly. This still needs KMS driver name mapping to kmsro to be used automatically. Acked-by: Eric Anholt <[email protected]> Signed-off-by: Rob Herring <[email protected]>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 2ebce75b13b..344140d6a4a 100644
--- a/meson.build
+++ b/meson.build
@@ -213,8 +213,8 @@ endif
if with_gallium_imx and not with_gallium_etnaviv
error('IMX driver requires etnaviv driver')
endif
-if with_gallium_kmsro and not with_gallium_vc4
- error('kmsro driver requires vc4 driver')
+if with_gallium_kmsro and not (with_gallium_vc4 or with_gallium_etnaviv)
+ error('kmsro driver requires one or more renderonly drivers (vc4, etnaviv)')
endif
if with_gallium_tegra and not with_gallium_nouveau
error('tegra driver requires nouveau driver')