summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorJason Ekstrand <[email protected]>2017-11-11 10:28:54 -0800
committerJason Ekstrand <[email protected]>2017-11-13 11:54:44 -0800
commit3a922d6a613231212b6ea7276d1ca416378bd9fd (patch)
tree755dd08423cfbd91d729e8039664140345ae5010 /meson.build
parentda31e2c22d72af041a4558b30eb354ff17f000ba (diff)
meson: Stop requiring platforms for Vulkan
It should be perfectly valid to build a completely headless Vulkan driver. We don't need to require a platform. Reviewed-by: Dylan Baker <[email protected]>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 0 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index 1f6658bbacf..e4d0e0f80cb 100644
--- a/meson.build
+++ b/meson.build
@@ -306,9 +306,6 @@ if _vulkan_drivers != ''
with_intel_vk = _split.contains('intel')
with_amd_vk = _split.contains('amd')
with_any_vk = with_amd_vk or with_intel_vk
- if not (with_platform_x11 or with_platform_wayland or with_platform_android)
- error('Vulkan requires at least one platform (x11, wayland, android)')
- endif
endif
with_dri2 = (with_dri or with_any_vk) and with_dri_platform == 'drm'