summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorNicolai Hähnle <[email protected]>2017-11-15 12:41:58 +0100
committerNicolai Hähnle <[email protected]>2017-11-16 06:45:35 +0100
commit2e3d0dd6c8f405f27d68b1ac35e928233bf8b89c (patch)
tree547b3b7677d9d5879504885c45eaefe498691280 /meson.build
parenta8bdf0e0c4c792634551c14e2dd02d72b75a8db5 (diff)
threads,configure.ac,meson.build: define and use HAVE_TIMESPEC_GET
Tested with Travis and Appveyor. v2: add HAVE_TIMESPEC_GET for non-Windows Scons builds v3: use check_functions in Scons (Eric) Cc: Rob Herring <[email protected]> Cc: Alexander von Gluck IV <[email protected]> Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=103674 Fixes: f1a364878431 ("threads: update for late C11 changes") Reviewed-by: Eric Engestrom <[email protected]> Reviewed-by: Dylan Baker <[email protected]> Reviewed-by: Jon Turney <[email protected]> (v2)
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 1c4200705f3..7fdc3c280e6 100644
--- a/meson.build
+++ b/meson.build
@@ -578,7 +578,7 @@ foreach h : ['xlocale.h', 'sys/sysctl.h', 'linux/futex.h']
endif
endforeach
-foreach f : ['strtof', 'mkostemp', 'posix_memalign']
+foreach f : ['strtof', 'mkostemp', 'posix_memalign', 'timespec_get']
if cc.has_function(f)
pre_args += '-DHAVE_@0@'.format(f.to_upper())
endif