summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorJon Turney <[email protected]>2017-11-23 13:42:00 +0000
committerJon Turney <[email protected]>2017-11-30 15:09:21 +0000
commitdbe36e3b1788a333309c5b919a40bceaf0df3e74 (patch)
tree087c56eb17a8ea9bb120ee2b5893ac6920d2ddfe /meson.build
parent9cdd41b18ae268d8ef99dbd766f4cb85c0ee315e (diff)
meson: set _GNU_SOURCE on cygwin
Signed-off-by: Jon Turney <[email protected]> Reviewed-by: Dylan Baker <[email protected]> Reviewed-by: Eric Engestrom <[email protected]>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index a7a51bccb33..7a7793b9961 100644
--- a/meson.build
+++ b/meson.build
@@ -481,7 +481,7 @@ if cc.compiles('int foo(void) { return 0; } int bar(void) __attribute__((alias("
endif
# TODO: this is very incomplete
-if host_machine.system() == 'linux'
+if ['linux', 'cygwin'].contains(host_machine.system())
pre_args += '-D_GNU_SOURCE'
endif