summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDylan Baker <[email protected]>2017-10-10 14:56:39 -0700
committerDylan Baker <[email protected]>2017-10-16 16:32:43 -0700
commit6a9ad20b7c989d0a35f738d33c34bb2ee7c82695 (patch)
tree9e31601de5074db4c4b09e381055b4d64cc4ccb5 /meson.build
parentde24d61765011ed4bfc169b8ad8cf67e86b1f3bd (diff)
meson: build llvmpipe
Signed-off-by: Dylan Baker <[email protected]> Reviewed-by: Eric Anholt <[email protected]>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 3 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index e96dc864986..bc3bbf41a65 100644
--- a/meson.build
+++ b/meson.build
@@ -589,7 +589,9 @@ if with_llvm
'-DMESA_LLVM_VERSION_PATCH=@0@'.format(_llvm_patch),
]
else
- if with_amd_vk or with_gallium_radeonsi
+ if with_gallium_softpipe
+ error('Cannot find LLVM to build LLVMPipe. If you wanted softpipe pass -Dllvm=false to meson')
+ elif with_amd_vk or with_gallium_radeonsi # etc
error('The following drivers requires LLVM: Radv, RadeonSI. One of these is enabled, but LLVM was not found.')
endif
endif