summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDylan Baker <[email protected]>2017-10-09 14:22:07 -0700
committerDylan Baker <[email protected]>2017-10-16 16:32:43 -0700
commit601bd7296fa464fe146f57c4ea89e3cad06749e9 (patch)
tree7c9019c5722a879e78bb2b15d6b21a1f3fb80a6a /meson.build
parente21e0a6a70b84f384ac7b80b88415e8fa519026d (diff)
meson: Set _GNU_SOURCE
When we start adding non-free software platforms support we'll need to guard this, but for now it should be fine as is. Signed-off-by: Dylan Baker <[email protected]> Reviewed-by: Eric Anholt <[email protected]>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 2f73215ca52..e68469262bf 100644
--- a/meson.build
+++ b/meson.build
@@ -31,6 +31,7 @@ pre_args = [
'-DVERSION="@0@"'.format(meson.project_version()),
'-DPACKAGE_VERSION=VERSION',
'-DPACKAGE_BUGREPORT="https://bugs.freedesktop.org/enter_bug.cgi?product=Mesa"',
+ '-D_GNU_SOURCE',
]
with_vulkan_icd_dir = get_option('vulkan-icd-dir')