summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDylan Baker <[email protected]>2018-08-14 09:31:41 -0700
committerDylan Baker <[email protected]>2018-08-16 13:50:51 -0700
commit52194ae4df18c7211cef69354a686eabc297a18d (patch)
tree59c84b5fc222a0974a9012bccbd75ea6455b574e /meson.build
parent03ec67221309b641e690418572b23a24b30eb9a8 (diff)
meson: Ensure that mako is >= 0.8.0
It's what autotools has required for a long time. v3: - Use distutils.version.StrictVersion instead of comparing strings Reviewed-by: Eric Engestrom <[email protected]> Reviewed-by: Jose Fonseca <[email protected]>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build10
1 files changed, 8 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 7436164946b..c9ef70346a1 100644
--- a/meson.build
+++ b/meson.build
@@ -698,9 +698,15 @@ if with_platform_haiku
endif
prog_python = find_program('python3')
-has_mako = run_command(prog_python, '-c', 'import mako')
+has_mako = run_command(
+ prog_python, '-c',
+ '''
+from distutils.version import StrictVersion
+import mako
+assert StrictVersion(mako.__version__) > StrictVersion("0.8.0")
+ ''')
if has_mako.returncode() != 0
- error('Python (3.x) mako module required to build mesa.')
+ error('Python (3.x) mako module >= 0.8.0 required to build mesa.')
endif
if cc.get_id() == 'gcc' and cc.version().version_compare('< 4.4.6')