summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorEric Engestrom <[email protected]>2017-12-04 15:06:03 +0000
committerEric Engestrom <[email protected]>2017-12-07 17:21:03 +0000
commitf0337f0f701fc904d7c32556b8621438b2a45b3f (patch)
tree42ba9cf0b2c06f2d5707942235c71f033485b7ea /meson.build
parent5f81a43535e8512cef26ea3dcd1e3a489bd5a1bb (diff)
meson: fix pl111 dependency on vc4
src/gallium/winsys/pl111/drm/libpl111winsys.a(pl111_drm_winsys.c.o): In function `pl111_drm_screen_create': pl111_drm_winsys.c:(.text+0x33): undefined reference to `vc4_drm_screen_create_renderonly' Signed-off-by: Eric Engestrom <[email protected]> Reviewed-by: Dylan Baker <[email protected]>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 3e8ea7d17e0..1ea63fb1291 100644
--- a/meson.build
+++ b/meson.build
@@ -190,6 +190,9 @@ endif
if with_gallium_imx and not with_gallium_etnaviv
error('IMX driver requires etnaviv driver')
endif
+if with_gallium_pl111 and not with_gallium_vc4
+ error('pl111 driver requires vc4 driver')
+endif
dep_libdrm_intel = []
if with_dri_i915 or with_gallium_i915