summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorEric Anholt <[email protected]>2017-11-08 14:07:38 -0800
committerEric Anholt <[email protected]>2017-11-09 09:40:30 -0800
commitebcb4c2156e9c0900fce6ee9ce6e3bd7894f7953 (patch)
tree1b761dbfc7978b142bfb875d70aa4c0ae659160a /meson.build
parent9c9fd8ff3792897a5fe3c3998274e59fa95d4d76 (diff)
meson: Enable VC4's NEON assembly support.
Reviewed-by: Dylan Baker <[email protected]> Reviewed-by: Eric Engestrom <[email protected]> Tested-by: Timothy Arceri <[email protected]>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index ce97fa95af7..ddd76804c54 100644
--- a/meson.build
+++ b/meson.build
@@ -489,8 +489,8 @@ endif
# FIXME: enable asm when cross compiler
# This is doable (autotools does it), but it's not of immediate concern
-if meson.is_cross_build()
- message('Cross compiling, disabling asm')
+if meson.is_cross_build() and host_machine.cpu_family().startswith('x86')
+ message('Cross compiling, disabling x86/x86_64 asm')
with_asm = false
endif