summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorMaya Rashish <[email protected]>2019-09-03 11:55:34 +0300
committerEric Engestrom <[email protected]>2019-09-30 18:38:14 +0000
commitc0330461c9a8fcc86227489b35ff143e5d7ee2ab (patch)
treeacc926faa805db43dbe185b82226c31d04347a9f /meson.build
parent4913ad9a37ecc71ae1b5c497c17d639e30c35d15 (diff)
meson: Test for -Wl,--build-id=sha1
instead of hard-coding OS list. Helps Solaris ld builds. Reviewed-by: Eric Engestrom <[email protected]> Reviewed-by: Erik Faye-Lund <[email protected]> Signed-off-by: Maya Rashish <[email protected]>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 2 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index 9fe017d5455..5ceda5c7969 100644
--- a/meson.build
+++ b/meson.build
@@ -1123,10 +1123,8 @@ if cc.links('int main() { return 0; }',
name : 'dynamic-list')
with_ld_dynamic_list = true
endif
-ld_args_build_id = []
-if build_machine.system() != 'darwin'
- ld_args_build_id += '-Wl,--build-id=sha1'
-endif
+
+ld_args_build_id = cc.get_supported_link_arguments('-Wl,--build-id=sha1')
# check for dl support
dep_dl = null_dep