summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorJon Turney <[email protected]>2017-11-13 10:13:54 +0000
committerJon Turney <[email protected]>2017-11-14 12:00:25 +0000
commit7df9a3609a5d8f7db57270d226145f9678749a0b (patch)
tree3e12759bebe7eed773064f645205fff0b7528e6f /meson.build
parent7c255788637b8fdfc31aca5f7891f39a110c5cb2 (diff)
meson: if dep_dl is an empty list, it's not a dependency object
It's ok to use an empty list for dependencies:, but it's not ok to try to use the found() method of it. See also https://github.com/mesonbuild/meson/issues/2324 Signed-off-by: Jon Turney <[email protected]> Reviewed-by: Eric Engestrom <[email protected]> Reviewed-by: Dylan Baker <[email protected]>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index e8467590df2..1c4200705f3 100644
--- a/meson.build
+++ b/meson.build
@@ -922,7 +922,7 @@ endif
if dep_m.found()
gl_priv_libs += '-lm'
endif
-if dep_dl.found()
+if dep_dl != [] and dep_dl.found()
gl_priv_libs += '-ldl'
endif