summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDylan Baker <[email protected]>2018-11-09 13:27:56 -0800
committerEmil Velikov <[email protected]>2018-11-14 18:53:02 +0000
commit6a706763d0266bb1c4f86faff8b8a71fd4386641 (patch)
tree379e589085ca30eb705e730af31e9876a035d4ea /meson.build
parent9b8380a4f9ca28b2ba569c272e4951084b011210 (diff)
meson: Don't set -Wall
meson does this for you with its warn levels, so we don't need to set it ourselves. Fixes: d1992255bb29054fa51763376d125183a9f602f3 ("meson: Add build Intel "anv" vulkan driver") Reviewed-by: Eric Engestrom <[email protected]> (cherry picked from commit 9c2a95b29868f1388408b5eb9193fff39f942217)
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 18667988bac..dabfb9abddd 100644
--- a/meson.build
+++ b/meson.build
@@ -787,7 +787,7 @@ endif
# Check for generic C arguments
c_args = []
-foreach a : ['-Wall', '-Werror=implicit-function-declaration',
+foreach a : ['-Werror=implicit-function-declaration',
'-Werror=missing-prototypes', '-Werror=return-type',
'-fno-math-errno',
'-fno-trapping-math', '-Qunused-arguments']
@@ -809,7 +809,7 @@ endif
# Check for generic C++ arguments
cpp_args = []
-foreach a : ['-Wall', '-Werror=return-type',
+foreach a : ['-Werror=return-type',
'-fno-math-errno', '-fno-trapping-math',
'-Qunused-arguments']
if cpp.has_argument(a)