summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorEric Engestrom <[email protected]>2017-11-06 17:18:06 +0000
committerEric Engestrom <[email protected]>2017-11-07 11:01:32 +0000
commit1e6f9ea21230229c0256d8189427411298132638 (patch)
treeadcc8e65ecf090ddf593063f536d4e12052508c1 /meson.build
parentd5597f09c6a18a3ed2dd76657dd2e60806a6e4b2 (diff)
meson: only turn on Mesa's DEBUG for buildtype==debug
As discussed in this thread: https://lists.freedesktop.org/archives/mesa-dev/2017-November/175104.html Cc: Dylan Baker <[email protected]> Signed-off-by: Eric Engestrom <[email protected]> Acked-by: Andres Rodriguez <[email protected]> Reviewed-by: Chad Versace <[email protected]> Reviewed-by: Matt Turner <[email protected]> Tested-by: Chad Versace <[email protected]>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 6e9a799704e..44e062e01e9 100644
--- a/meson.build
+++ b/meson.build
@@ -349,8 +349,8 @@ if cc.get_id() == 'gcc' and cc.version().version_compare('< 4.4.6')
error('When using GCC, version 4.4.6 or later is required.')
endif
-# Define DEBUG for debug and debugoptimized builds
-if get_option('buildtype').startswith('debug')
+# Define DEBUG for debug builds only (debugoptimized is not included on this one)
+if get_option('buildtype') == 'debug'
pre_args += '-DDEBUG'
endif