summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorEric Engestrom <[email protected]>2017-10-24 16:08:15 +0100
committerEric Engestrom <[email protected]>2017-10-30 16:32:05 +0000
commitc5ec1556859b7d33637c9fad13d3473c7b2f9eb3 (patch)
tree3538e85b0c9afe7f3fe0f7fcbea4c9a5d5aee0d5 /meson.build
parent6403efbe7458d05cf117adb41c8a152ed6e28bdd (diff)
meson: wire up egl/android
Cc: Rob Herring <[email protected]> Cc: Tomasz Figa <[email protected]> Signed-off-by: Eric Engestrom <[email protected]> Reviewed-by: Dylan Baker <[email protected]>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build15
1 files changed, 12 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index 8988deae783..24d997b3e0a 100644
--- a/meson.build
+++ b/meson.build
@@ -150,7 +150,7 @@ endif
# TODO: other OSes
with_dri_platform = 'drm'
-# TODO: android platform
+with_platform_android = false
with_platform_wayland = false
with_platform_x11 = false
with_platform_drm = false
@@ -159,6 +159,7 @@ egl_native_platform = ''
_platforms = get_option('platforms')
if _platforms != ''
_split = _platforms.split(',')
+ with_platform_android = _split.contains('android')
with_platform_x11 = _split.contains('x11')
with_platform_wayland = _split.contains('wayland')
with_platform_drm = _split.contains('drm')
@@ -250,8 +251,8 @@ if _vulkan_drivers != ''
with_intel_vk = _split.contains('intel')
with_amd_vk = _split.contains('amd')
with_any_vk = with_amd_vk or with_intel_vk
- if not (with_platform_x11 or with_platform_wayland)
- error('Vulkan requires at least one platform (x11, wayland)')
+ if not (with_platform_x11 or with_platform_wayland or with_platform_android)
+ error('Vulkan requires at least one platform (x11, wayland, android)')
endif
endif
@@ -328,6 +329,14 @@ endif
if with_platform_surfaceless
pre_args += '-DHAVE_SURFACELESS_PLATFORM'
endif
+if with_platform_android
+ dep_android = [
+ dependency('cutils'),
+ dependency('hardware'),
+ dependency('sync'),
+ ]
+ pre_args += '-DHAVE_ANDROID_PLATFORM'
+endif
prog_python2 = find_program('python2')
has_mako = run_command(prog_python2, '-c', 'import mako')