summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDylan Baker <[email protected]>2018-03-12 15:58:40 -0700
committerDylan Baker <[email protected]>2018-03-29 10:18:47 -0700
commitacadf06f564da15c0bfc44265e804b866fbb9cb3 (patch)
tree216993bb1490b3d362d4fe4f02a49a926a8da538 /meson.build
parente520ca562a410d3dc3708515b44ca09a50c59830 (diff)
meson: group libdrm dependencies
The reason libdrm is after libdrm_* will be made clear in later patches. Signed-off-by: Dylan Baker <[email protected]> Reviewed-by: Eric Engestrom <[email protected]>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build29
1 files changed, 14 insertions, 15 deletions
diff --git a/meson.build b/meson.build
index f210eeb2530..cfb40deaafe 100644
--- a/meson.build
+++ b/meson.build
@@ -230,11 +230,6 @@ if with_gallium_tegra and not with_gallium_nouveau
error('tegra driver requires nouveau driver')
endif
-dep_libdrm_intel = []
-if with_dri_i915 or with_gallium_i915
- dep_libdrm_intel = dependency('libdrm_intel', version : '>= 2.4.75')
-endif
-
if host_machine.system() == 'darwin'
with_dri_platform = 'apple'
elif ['windows', 'cygwin'].contains(host_machine.system())
@@ -1005,16 +1000,6 @@ else
dep_clock = cc.find_library('rt')
endif
-with_gallium_drisw_kms = false
-dep_libdrm = dependency('libdrm', version : '>= 2.4.75',
- required : with_dri2 or with_dri3)
-if dep_libdrm.found()
- pre_args += '-DHAVE_LIBDRM'
- if with_dri_platform == 'drm' and with_dri
- with_gallium_drisw_kms = true
- endif
-endif
-
# TODO: some of these may be conditional
dep_zlib = dependency('zlib', version : '>= 1.2.3')
pre_args += '-DHAVE_ZLIB'
@@ -1040,6 +1025,10 @@ dep_libdrm_radeon = []
dep_libdrm_nouveau = []
dep_libdrm_etnaviv = []
dep_libdrm_freedreno = []
+dep_libdrm_intel = []
+if with_dri_i915 or with_gallium_i915
+ dep_libdrm_intel = dependency('libdrm_intel', version : '>= 2.4.75')
+endif
if with_amd_vk or with_gallium_radeonsi
dep_libdrm_amdgpu = dependency('libdrm_amdgpu', version : '>= 2.4.91')
endif
@@ -1057,6 +1046,16 @@ if with_gallium_freedreno
dep_libdrm_freedreno = dependency('libdrm_freedreno', version : '>= 2.4.91')
endif
+with_gallium_drisw_kms = false
+dep_libdrm = dependency('libdrm', version : '>= 2.4.75',
+ required : with_dri2 or with_dri3)
+if dep_libdrm.found()
+ pre_args += '-DHAVE_LIBDRM'
+ if with_dri_platform == 'drm' and with_dri
+ with_gallium_drisw_kms = true
+ endif
+endif
+
llvm_modules = ['bitwriter', 'engine', 'mcdisassembler', 'mcjit']
if with_amd_vk or with_gallium_radeonsi or with_gallium_r600
llvm_modules += ['amdgpu', 'bitreader', 'ipo']