summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDylan Baker <[email protected]>2017-10-27 21:08:07 -0700
committerJon Turney <[email protected]>2018-02-05 19:40:43 +0000
commit569628dd24f85ebddf263b6d974f0bc07c0e46dc (patch)
tree36bdf094ad18789c145318a1553d65cc8115dc4f /meson.build
parent4772909447d1c214603270bee29df650e5a955b7 (diff)
meson: set apple glx defines
Reviewed-by: Jon Turney <[email protected]> Reviewed-by: Emil Velikov <[email protected]>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index d6ffa30d9e5..030ab0c6260 100644
--- a/meson.build
+++ b/meson.build
@@ -617,6 +617,8 @@ if with_platform_x11
endif
if with_dri_platform == 'drm'
pre_args += '-DGLX_USE_DRM'
+ elif with_dri_platform == 'apple'
+ pre_args += '-DGLX_USE_APPLEGL'
elif with_dri_platform == 'windows'
pre_args += '-DGLX_USE_WINDOWSGL'
endif