summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorJon Turney <[email protected]>2018-01-25 18:53:08 +0000
committerEmil Velikov <[email protected]>2018-02-05 19:06:01 +0000
commit8c827600edf5f0a8ce33ffb4c5c310aae298df13 (patch)
tree9f83e7a99bf209e63881f844c4616f933b686cac /meson.build
parentc369ec95d907953320b4e3cc6498b85e38757f4d (diff)
meson: libdrm shouldn't appear in Requires.private: if it wasn't found
Otherwise, using pkg-config to retrieve flags will fail, e.g. $ pkg-config gl --cflags Package libdrm was not found in the pkg-config search path. Perhaps you should add the directory containing `libdrm.pc' to the PKG_CONFIG_PATH environment variable Package 'libdrm', required by 'gl', not found Fixes: 3218056e0eb3 ("meson: Build i965 and dri stack") Reviewed-by: Dylan Baker <[email protected]> Signed-off-by: Jon Turney <[email protected]> (cherry picked from commit 4a0bab1d7f942ad0ac9b98ab34e6a9e4694f3c04)
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 4 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 1a31f397331..11d8ac0a9bb 100644
--- a/meson.build
+++ b/meson.build
@@ -1219,8 +1219,10 @@ inc_include = include_directories('include')
gl_priv_reqs = [
'x11', 'xext', 'xdamage >= 1.1', 'xfixes', 'x11-xcb', 'xcb',
- 'xcb-glx >= 1.8.1', 'libdrm >= 2.4.75',
-]
+ 'xcb-glx >= 1.8.1']
+if dep_libdrm.found()
+ gl_priv_reqs += 'libdrm >= 2.4.75'
+endif
if dep_xxf86vm != [] and dep_xxf86vm.found()
gl_priv_reqs += 'xxf86vm'
endif