summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorMarc Dietrich <[email protected]>2018-01-24 22:03:51 +0100
committerJuan A. Suarez Romero <[email protected]>2018-04-14 16:15:56 +0200
commit825e950aeae92b71ce4cee1df8c70cf81664cb6e (patch)
tree540729ea987c984a8e008db7fdf8791b32b830c0 /meson.build
parenta989e999b41f2e6c48261c0a2b8aba8258dc97dc (diff)
meson: fix HAVE_LLVM version define in meson build
LLVM patch level is not included in HAVE_LLVM. Fixes: e6418ab1566d ("meson: build "radv" vulkan driver for radeon hardware") Reviewed-by: Eric Engestrom <[email protected]> Reviewed-by: Dylan Baker <[email protected]> Signed-off-by: Marc Dietrich <[email protected]> (cherry picked from commit a2a1b0e75ef9adeb17468509c5f6331b42f6dc2e)
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 341d9ae5b43..3f9cc1f9009 100644
--- a/meson.build
+++ b/meson.build
@@ -1027,7 +1027,7 @@ if with_llvm
_llvm_patch = _llvm_patch.split('g')[0]
endif
pre_args += [
- '-DHAVE_LLVM=0x0@0@@1@@2@'.format(_llvm_version[0], _llvm_version[1], _llvm_patch),
+ '-DHAVE_LLVM=0x0@0@0@1@'.format(_llvm_version[0], _llvm_version[1]),
'-DMESA_LLVM_VERSION_PATCH=@0@'.format(_llvm_patch),
]
elif with_amd_vk or with_gallium_radeonsi or with_gallium_swr