summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorVille Syrjälä <[email protected]>2017-10-10 01:15:42 +0300
committerVille Syrjälä <[email protected]>2017-10-13 14:29:00 +0300
commit2289964f4f2aede298317d89bc96d9e2aa3ff766 (patch)
tree23af71b43b81464c346b0792b54a5c803ee20280 /meson.build
parent66b1597a88f7c58eb45f29883ebf5235c1abb952 (diff)
meson: Build i915
Build i915 with meson. More or less copied from i965, with all the unneeded cruft removed, and the libdrm_intel dependency added. Cc: Dylan Baker <[email protected]> Cc: Eric Anholt <[email protected]> Signed-off-by: Ville Syrjälä <[email protected]> Reviewed-by: Eric Anholt <[email protected]> Reviewed-by: Dylan Baker <[email protected]>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 7 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 4ba00283cec..02264aeed4e 100644
--- a/meson.build
+++ b/meson.build
@@ -72,16 +72,23 @@ if (with_gles1 or with_gles2) and not with_opengl
endif
with_dri = false
+with_dri_i915 = false
with_dri_i965 = false
with_dri_swrast = false
_drivers = get_option('dri-drivers')
if _drivers != ''
_split = _drivers.split(',')
+ with_dri_i915 = _split.contains('i915')
with_dri_i965 = _split.contains('i965')
with_dri_swrast = _split.contains('swrast')
with_dri = true
endif
+dep_libdrm_intel = []
+if with_dri_i915
+ dep_libdrm_intel = dependency('libdrm_intel', version : '>= 2.4.75')
+endif
+
if not with_dri
with_gles1 = false
with_gles2 = false