summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDylan Baker <[email protected]>2017-10-16 17:24:56 -0700
committerDylan Baker <[email protected]>2017-10-26 11:30:56 -0700
commiteecd2860ffc89bf1c699dcb41e00205f8fa7e08a (patch)
tree3e251e30ddebc6c867e9498c4b947ac60e616691 /meson.build
parent191e785c8101233ecf018b6bd4f62f969352199a (diff)
meson: build r200 driver
v2: - remove TODO that is done Build tested only Signed-off-by: Dylan Baker <[email protected]> Reviewed-by: Eric Anholt <[email protected]>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 3 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 5ca5c64954a..b6293760faf 100644
--- a/meson.build
+++ b/meson.build
@@ -88,6 +88,7 @@ with_dri = false
with_dri_i915 = false
with_dri_i965 = false
with_dri_r100 = false
+with_dri_r200 = false
with_dri_swrast = false
_drivers = get_option('dri-drivers')
if _drivers != ''
@@ -95,6 +96,7 @@ if _drivers != ''
with_dri_i915 = _split.contains('i915')
with_dri_i965 = _split.contains('i965')
with_dri_r100 = _split.contains('r100')
+ with_dri_r200 = _split.contains('r200')
with_dri_swrast = _split.contains('swrast')
with_dri = true
endif
@@ -629,7 +631,7 @@ dep_libdrm_freedreno = []
if with_amd_vk or with_gallium_radeonsi
dep_libdrm_amdgpu = dependency('libdrm_amdgpu', version : '>= 2.4.85')
endif
-if with_gallium_radeonsi or with_dri_r100 # older radeon too
+if with_gallium_radeonsi or with_dri_r100 or with_dri_r200
dep_libdrm_radeon = dependency('libdrm_radeon', version : '>= 2.4.71')
endif
if with_gallium_nouveau