summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorScott D Phillips <[email protected]>2018-01-24 11:24:12 -0800
committerEmil Velikov <[email protected]>2018-01-26 19:53:01 +0000
commit12afb389d64ef20c81b45ff4277aa9ffc72092c1 (patch)
treedcda390d86b4e9c7ed14eb9224d2c8e7c1e3bdab /meson.build
parent2d7035ee48ce2f6f502243f1b8d51a5339172788 (diff)
meson: Fix define for USE_SSE41
Before we were adding -DHAVE_SSE41 which isn't what the code is looking for, so some uses of the sse4.1 code were always being skipped. v2: Don't add any compile check for the quite old -msse4.1 option (Dylan) Fixes: 84486f6462 ("meson: Enable SSE4.1 optimizations") Reviewed-by: Dylan Baker <[email protected]> (cherry picked from commit 0b8d38bd48b219bd979b2ee0ef1ce2b7184f7095)
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index aacda0659e3..af5a7ea3eff 100644
--- a/meson.build
+++ b/meson.build
@@ -774,7 +774,7 @@ foreach a : ['-Werror=pointer-arith', '-Werror=vla']
endforeach
if host_machine.cpu_family().startswith('x86')
- pre_args += '-DHAVE_SSE41'
+ pre_args += '-DUSE_SSE41'
with_sse41 = true
sse41_args = ['-msse4.1']