summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2018-12-13 03:54:03 +0000
committerEmil Velikov <[email protected]>2018-12-13 03:54:03 +0000
commit9d10581897ef7cfa0f6c392e2048cc04357281b9 (patch)
tree6dfd7e06b6ec02e53da99de30c1855cd6d5df0f9 /meson.build
parente0dbfc995370756355f28ac31495eab96a410384 (diff)
meson: don't require glx/egl/gbm with gallium drivers
The gallium drivers do not require a DRI loader. Drop the artificial and unnecessary restriction. Fixes: af9d276134d ("meson: build libmesa_gallium") Signed-off-by: Emil Velikov <[email protected]> Reviewed-by: Dylan Baker <[email protected]>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 3 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index 5515f2605d5..9ecb8ea20ca 100644
--- a/meson.build
+++ b/meson.build
@@ -381,9 +381,9 @@ endif
if with_any_vk and (with_platform_x11 and not with_dri3)
error('Vulkan drivers require dri3 for X11 support')
endif
-if with_dri or with_gallium
- if with_glx == 'disabled' and not with_egl and not with_platform_haiku
- error('building dri or gallium drivers require at least one window system')
+if with_dri
+ if with_glx == 'disabled' and not with_egl and not with_gbm
+ error('building dri drivers require at least one windowing system')
endif
endif