summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDylan Baker <[email protected]>2017-11-15 17:31:32 -0800
committerDylan Baker <[email protected]>2017-11-22 12:47:43 -0800
commit4b61b07e4b61fdb8ed90a02f3716e608b4d10fc8 (patch)
treef47579e648097659546c4e7e46fe6d7d156561e1 /meson.build
parentb5d98a101bf57f8648f32637f504af9e60fb223e (diff)
meson: Convert platform to auto
This is necessary to support operating systems other than the *nix family (excluding macOS). For Linux nothing has changed, the defaults are still the same. Signed-off-by: Dylan Baker <[email protected]> Reviewed-by: Eric Engestrom <[email protected]>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 7 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index fe3eb8ee210..f8007dff0e8 100644
--- a/meson.build
+++ b/meson.build
@@ -198,6 +198,13 @@ with_platform_drm = false
with_platform_surfaceless = false
egl_native_platform = ''
_platforms = get_option('platforms')
+if _platforms == 'auto'
+ if ['linux'].contains(host_machine.system())
+ _platforms = 'x11,wayland,drm,surfaceless'
+ else
+ error('Unknown OS, no platforms enabled. Patches gladly accepted to fix this.')
+ endif
+endif
if _platforms != ''
_split = _platforms.split(',')
with_platform_android = _split.contains('android')