summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorEric Anholt <[email protected]>2017-10-12 13:53:12 -0700
committerEric Anholt <[email protected]>2017-10-17 13:41:59 -0700
commit1ae8018a6af81eec4832a57d9d0346aa3dd98d28 (patch)
treeeff20ab270ce164b1bd978ac51bfe6b6a0b31372 /meson.build
parent2f4705afde707e8eb41b9414c25df91aa1ea2fb3 (diff)
meson: Add support for the vc4 driver.
Reviewed-by: Dylan Baker <[email protected]>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index bc3bbf41a65..f538cf79bb4 100644
--- a/meson.build
+++ b/meson.build
@@ -94,12 +94,14 @@ with_gallium = false
with_gallium_radeonsi = false
with_gallium_nouveau = false
with_gallium_softpipe = false
+with_gallium_vc4 = false
_drivers = get_option('gallium-drivers')
if _drivers != ''
_split = _drivers.split(',')
with_gallium_radeonsi = _split.contains('radeonsi')
with_gallium_nouveau = _split.contains('nouveau')
with_gallium_softpipe = _split.contains('swrast')
+ with_gallium_vc4 = _split.contains('vc4')
with_gallium = true
with_dri = true
endif