summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDylan Baker <[email protected]>2017-10-24 15:52:57 -0700
committerDylan Baker <[email protected]>2017-10-27 11:06:45 -0700
commitf121a669c7d94d2ff6721e01bec72589fd081ab3 (patch)
tree419549096edb13c6afe20c600cb7005e24d5fd17 /meson.build
parentcbbd5bb889a2c271a504c379f36a7cb717a85af4 (diff)
meson: build gallium based osmesa
This has been tested with the osdemo from mesa-demos v2: - Add SELinux dependency - fix typo GALLIUM_LLVM -> GALLIUM_LLVMPIPE Signed-off-by: Dylan Baker <[email protected]> Reviewed-by: Eric Engestrom <[email protected]>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index ef06ea8f6b7..8988deae783 100644
--- a/meson.build
+++ b/meson.build
@@ -715,6 +715,9 @@ if with_osmesa != 'none'
if with_osmesa == 'classic' and not with_dri_swrast
error('OSMesa classic requires dri (classic) swrast.')
endif
+ if with_osmesa == 'gallium' and not with_gallium_softpipe
+ error('OSMesa gallium requires gallium softpipe or llvmpipe.')
+ endif
osmesa_lib_name = 'OSMesa'
osmesa_bits = get_option('osmesa-bits')
if osmesa_bits != '8'