summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorEric Engestrom <[email protected]>2018-03-12 14:54:50 +0000
committerEric Engestrom <[email protected]>2018-03-22 11:59:12 +0000
commitcb2ddcefa5196fdfeff76f405175c7a6c110eae4 (patch)
tree936dd7639f4f93ad259b37573c7fcb2cdef5618f /meson.build
parent880c1718b6d14b33fe5ba918af70fea5be890c6b (diff)
meson: merge C and C++ compiler arguments check
Signed-off-by: Eric Engestrom <[email protected]> Reviewed-by: Emil Velikov <[email protected]> Reviewed-by: Dylan Baker <[email protected]>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build17
1 files changed, 6 insertions, 11 deletions
diff --git a/meson.build b/meson.build
index 871b0d8d22f..6edb089db90 100644
--- a/meson.build
+++ b/meson.build
@@ -764,7 +764,9 @@ if ['linux', 'cygwin'].contains(host_machine.system())
pre_args += '-D_GNU_SOURCE'
endif
-# Check for generic C arguments
+# Check for generic C/C++ arguments
+cpp = meson.get_compiler('cpp')
+cpp_args = []
c_args = []
foreach a : ['-Wall', '-Werror=implicit-function-declaration',
'-Werror=missing-prototypes', '-fno-math-errno',
@@ -772,22 +774,15 @@ foreach a : ['-Wall', '-Werror=implicit-function-declaration',
if cc.has_argument(a)
c_args += a
endif
+ if cpp.has_argument(a)
+ cpp_args += a
+ endif
endforeach
c_vis_args = []
if cc.has_argument('-fvisibility=hidden')
c_vis_args += '-fvisibility=hidden'
endif
-# Check for generic C++ arguments
-cpp = meson.get_compiler('cpp')
-cpp_args = []
-foreach a : ['-Wall', '-fno-math-errno', '-fno-trapping-math',
- '-Qunused-arguments']
- if cpp.has_argument(a)
- cpp_args += a
- endif
-endforeach
-
# For some reason, the test for -Wno-foo always succeeds with gcc, even if the
# option is not supported. Hence, check for -Wfoo instead.
if cpp.has_argument('-Wnon-virtual-dtor')