summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorEric Engestrom <[email protected]>2018-02-23 17:08:20 +0000
committerEric Engestrom <[email protected]>2018-02-27 11:21:20 +0000
commit76e8d619996a6179af7506b77edad7a9fe3dbc63 (patch)
treeeed2e431cec6fa4b74bdf5763828a5f3bc181bcd /meson.build
parenta549da877bcf641b3ef2d915d551cd49fb3f300e (diff)
meson: simplify the gbm option code, and avoid changing types
v2: drop gallium comment (Dylan) Signed-off-by: Eric Engestrom <[email protected]> Reviewed-by: Dylan Baker <[email protected]>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build16
1 files changed, 7 insertions, 9 deletions
diff --git a/meson.build b/meson.build
index 6f2615f9d17..40e9c8ff452 100644
--- a/meson.build
+++ b/meson.build
@@ -294,16 +294,14 @@ if not (with_dri or with_gallium or with_glx == 'xlib' or with_glx == 'gallium-x
with_shared_glapi = false
endif
-with_gbm = get_option('gbm')
-if with_gbm == 'auto' and with_dri # TODO: or gallium
- with_gbm = system_has_kms_drm
-elif with_gbm == 'true'
- if not system_has_kms_drm
- error('GBM only supports DRM/KMS platforms')
- endif
- with_gbm = true
+_gbm = get_option('gbm')
+if _gbm == 'auto'
+ with_gbm = system_has_kms_drm and with_dri
else
- with_gbm = false
+ with_gbm = _gbm == 'true'
+endif
+if with_gbm and not system_has_kms_drm
+ error('GBM only supports DRM/KMS platforms')
endif
_egl = get_option('egl')