summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorMarek Olšák <[email protected]>2018-05-16 22:23:41 -0400
committerMarek Olšák <[email protected]>2018-05-17 14:54:41 -0400
commitf9eb1ef870eba9fdacf9a8cbd815ec3bff81db05 (patch)
tree41c8cc95b679a5b320d3282975fa8c394b01ecdb /meson.build
parent11a0d5563f49b84f27b2707d77a8553da52d73ba (diff)
amd: remove support for LLVM 4.0
It doesn't support GFX9. Acked-by: Dave Airlie <[email protected]> Acked-by: Samuel Pitoiset <[email protected]>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 3 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 0f88ddfe8e7..d0cb8961638 100644
--- a/meson.build
+++ b/meson.build
@@ -1107,7 +1107,9 @@ if with_gallium_opencl
# TODO: optional modules
endif
-if with_amd_vk or with_gallium_radeonsi or with_gallium_swr
+if with_amd_vk or with_gallium_radeonsi
+ _llvm_version = '>= 5.0.0'
+elif with_gallium_swr
_llvm_version = '>= 4.0.0'
elif with_gallium_opencl or with_gallium_r600
_llvm_version = '>= 3.9.0'