summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorEric Anholt <[email protected]>2017-08-25 15:34:22 -0700
committerEric Anholt <[email protected]>2018-05-16 21:19:07 +0100
commitc4c488a2aeb24c0f468664c0cacd0d01111a4e46 (patch)
treead560d93a05e5eae1227775c9e1627e67256d1bd /meson.build
parent8a793d42f1ccef2c87053a1d9a130b49cfb2b84f (diff)
v3d: Rename the vc5_dri.so driver to v3d_dri.so.
This allows the driver to load against the merged kernel DRM driver. In the process, rename most of the build system variables and gallium plumbing functions.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 3 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index 9a538e99511..b8ebda9cdc7 100644
--- a/meson.build
+++ b/meson.build
@@ -137,7 +137,7 @@ with_gallium_nouveau = false
with_gallium_freedreno = false
with_gallium_softpipe = false
with_gallium_vc4 = false
-with_gallium_vc5 = false
+with_gallium_v3d = false
with_gallium_etnaviv = false
with_gallium_imx = false
with_gallium_tegra = false
@@ -155,7 +155,7 @@ if _drivers.contains('auto')
]
elif ['arm', 'aarch64'].contains(host_machine.cpu_family())
_drivers = [
- 'pl111', 'vc4', 'vc5', 'freedreno', 'etnaviv', 'imx', 'nouveau',
+ 'pl111', 'v3d', 'vc4', 'freedreno', 'etnaviv', 'imx', 'nouveau',
'tegra', 'virgl', 'swrast',
]
else
@@ -175,8 +175,8 @@ if _drivers != ['']
with_gallium_nouveau = _drivers.contains('nouveau')
with_gallium_freedreno = _drivers.contains('freedreno')
with_gallium_softpipe = _drivers.contains('swrast')
+ with_gallium_v3d = _drivers.contains('v3d')
with_gallium_vc4 = _drivers.contains('vc4')
- with_gallium_vc5 = _drivers.contains('vc5')
with_gallium_etnaviv = _drivers.contains('etnaviv')
with_gallium_imx = _drivers.contains('imx')
with_gallium_tegra = _drivers.contains('tegra')