summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorMatt Turner <[email protected]>2018-06-06 20:25:09 -0700
committerMatt Turner <[email protected]>2018-06-07 14:16:44 -0700
commita5abb2da74d3a892427499961aaef194d9ce1edf (patch)
tree3d14d0f1f8195c410d69c8ba1ad83e934f1b7795 /meson.build
parent8f2421d73be596c12019196189255f22fd3edb54 (diff)
meson: Add support for read-only text segment on x86
Port of 6dfc5e28f7d0 (configure.ac: Add support to enable read-only text segment on x86.) to Meson. Reviewed-by: Dylan Baker <[email protected]>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 5 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index e6e2167ebe7..636d0f913ac 100644
--- a/meson.build
+++ b/meson.build
@@ -50,6 +50,7 @@ with_tests = get_option('build-tests')
with_valgrind = get_option('valgrind')
with_libunwind = get_option('libunwind')
with_asm = get_option('asm')
+with_glx_read_only_text = get_option('glx-read-only-text')
with_osmesa = get_option('osmesa')
with_swr_arches = get_option('swr-arches')
with_tools = get_option('tools')
@@ -874,6 +875,10 @@ if with_asm
with_asm_arch = 'x86'
pre_args += ['-DUSE_X86_ASM', '-DUSE_MMX_ASM', '-DUSE_3DNOW_ASM',
'-DUSE_SSE_ASM']
+
+ if with_glx_read_only_text
+ pre_args += ['-DGLX_X86_READONLY_TEXT']
+ endif
endif
elif host_machine.cpu_family() == 'x86_64'
if system_has_kms_drm