summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorEric Engestrom <[email protected]>2018-06-04 11:26:10 +0100
committerEric Engestrom <[email protected]>2018-06-05 10:38:57 +0100
commit7c4423cce98f95c3ab7349b3f7abc4a558cb6c48 (patch)
tree5fabb49b72922c6391283f92c54443d45caa3ad6 /meson.build
parent1ac4439d6278e6c5f9da5499bbc50362f0c6759b (diff)
meson: fix platforms check for `-D egl=true`
Fixes: 0ed6a87a106b6e2266e0 "meson: fix platforms=[]" Reported-by: Christoph Haag <[email protected]> Reviewed-by: Dylan Baker <[email protected]> Signed-off-by: Eric Engestrom <[email protected]>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 7b7c118d77b..1d1b2a979b1 100644
--- a/meson.build
+++ b/meson.build
@@ -292,7 +292,7 @@ elif _egl == 'true'
error('EGL requires dri')
elif not with_shared_glapi
error('EGL requires shared-glapi')
- elif with_platforms
+ elif not with_platforms
error('No platforms specified, consider -Dplatforms=drm,x11 at least')
elif not ['disabled', 'dri'].contains(with_glx)
error('EGL requires dri, but a GLX is being built without dri')