summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2018-02-23 19:32:03 +0000
committerEric Engestrom <[email protected]>2018-05-29 16:56:19 +0100
commit63b95fb291d7978e300c496cedc0851261101332 (patch)
treeb520d1a32288ca380a51f3f1524d0078059124bc /meson.build
parent728d1da159e072e7ef9956ba5326cc02f4d2589b (diff)
meson: require shared glapi when using DRI based libGL
Just like we do in the autotools build. Signed-off-by: Emil Velikov <[email protected]> Reviewed-by: Dylan Baker <[email protected]> Reviewed-by: Eric Engestrom <[email protected]>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 6 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index d4f460e0b6e..4aafba802a5 100644
--- a/meson.build
+++ b/meson.build
@@ -357,8 +357,12 @@ if with_glx != 'disabled'
if with_dri
error('xlib conflicts with any dri driver')
endif
- elif with_glx == 'dri' and not with_dri
- error('dri based GLX requires at least one DRI driver')
+ elif with_glx == 'dri'
+ if not with_dri
+ error('dri based GLX requires at least one DRI driver')
+ elif not with_shared_glapi
+ error('dri based GLX requires shared-glapi')
+ endif
endif
endif