summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDylan Baker <[email protected]>2017-09-28 22:25:02 -0700
committerDylan Baker <[email protected]>2017-10-16 16:32:43 -0700
commitb1b65397d0c4978e36a84c0a1c98a4bd6cb9588e (patch)
tree165535796a6ba46dcc4b64299ca8bd805838b827 /meson.build
parentaf9d276134d9af3b6145f10943eaf7bf1a6226b6 (diff)
meson: Build gallium auxiliary
v2: - guard gallivm files with "with_llvm" instead of "dep_llvm.found()" Signed-off-by: Dylan Baker <[email protected]> Reviewed-by: Eric Anholt <[email protected]> (v1)
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build36
1 files changed, 29 insertions, 7 deletions
diff --git a/meson.build b/meson.build
index 0ffa280b7e4..240c868675b 100644
--- a/meson.build
+++ b/meson.build
@@ -140,11 +140,13 @@ endif
# TODO: there are more platforms required for non-vulkan drivers
with_platform_wayland = false
with_platform_x11 = false
+with_platform_drm = false
_platforms = get_option('platforms')
if _platforms != ''
_split = _platforms.split(',')
with_platform_x11 = _split.contains('x11')
with_platform_wayland = _split.contains('wayland')
+ with_platform_drm = _split.contains('drm')
endif
with_gbm = get_option('gbm')
@@ -558,7 +560,10 @@ dep_selinux = []
# TODO: llvm-prefix and llvm-shared-libs
-# TODO: unwind (llvm [radeon, gallivm] and gallium)
+dep_unwind = dependency('libunwind', required : false)
+if dep_unwind.found()
+ pre_args += '-DHAVE_LIBUNWIND'
+endif
# TODO: flags for opengl, gles, dri
@@ -568,9 +573,6 @@ dep_selinux = []
# TODO: osmesa provider
-# TODO: flags for xa, egl, gbm, nin, xvmc, vdpau, omx, va, opencl,
-# gallium-tests,
-
# TODO: symbol mangling
# TODO: egl configuration
@@ -652,8 +654,6 @@ endif
# TODO: egl
-# TODO: xa
-
# TODO: vallium G3DVL
# TODO: nine
@@ -662,7 +662,29 @@ endif
# TODO: egl sans x11
-# TODO: xvmc
+with_gallium_xvmc = false
+with_gallium_vdpau = false
+with_gallium_omx = false # this is bellagio
+with_gallium_va = false
+with_gallium_media = false
+dep_va = []
+_drivers = get_option('gallium-media')
+if _drivers != ''
+ _split = _drivers.split(',')
+ with_gallium_xvmc = _split.contains('xvmc')
+ with_gallium_vdpau = _split.contains('vdpau')
+ with_gallium_omx = _split.contains('omx')
+ with_gallium_va = _split.contains('va')
+ with_gallium_media = (with_gallium_xvmc or with_gallium_vdpau or
+ with_gallium_omx or with_gallium_va)
+ if with_gallium_media
+ dep_va = [
+ dependency('x11-xcb'),
+ dependency('xcb'),
+ dependency('xcb-dri2', version : '>= 1.8'), # FIXME: dedup version
+ ]
+ endif
+endif
# TODO: gallium tests