summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorEric Engestrom <[email protected]>2019-03-05 12:32:13 +0000
committerEric Engestrom <[email protected]>2019-03-06 12:40:06 +0000
commitad862c36e5e175d9bf2d112927be7348fb3560f7 (patch)
treec8b166ca05a0533a6251c8ab61379815f0d32482 /meson.build
parentb49726afd43739979a08de6e410e78ead5a26337 (diff)
meson: fix with_dri2 definition for GNU Hurd
Suggested-by: Dylan Baker <[email protected]> Cc: Timo Aaltonen <[email protected]> Cc: James Clarke <[email protected]> Signed-off-by: Eric Engestrom <[email protected]> Reviewed-by: Dylan Baker <[email protected]>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 46f86eb0000..8a40c48e435 100644
--- a/meson.build
+++ b/meson.build
@@ -376,7 +376,8 @@ if with_vulkan_icd_dir == ''
with_vulkan_icd_dir = join_paths(get_option('datadir'), 'vulkan/icd.d')
endif
-with_dri2 = (with_dri or with_any_vk) and with_dri_platform == 'drm'
+with_dri2 = (with_dri or with_any_vk) and (with_dri_platform == 'drm' or
+ host_machine.system() == 'gnu')
_dri3 = get_option('dri3')
if _dri3 == 'auto'
with_dri3 = system_has_kms_drm and with_dri2