summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorChuck Atkins <[email protected]>2019-05-03 12:06:22 -0400
committerChuck Atkins <[email protected]>2019-05-03 13:36:25 -0400
commita381dbf2537003c8bf7e32ad314c9266846a168f (patch)
treee9ba064ffeea730fea0a43f9b1c367293c88420c /meson.build
parent4f18c43d1df64135e8968a7d4fbfd2c9918b76ae (diff)
meson: Fix missing glproto dependency for gallium-glx
Signed-off-by: Chuck Atkins <[email protected]> Cc: mesa-stable <[email protected]> Reviewed-by: Dylan Baker <[email protected]>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 4 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 2df33f26100..a637f3b1442 100644
--- a/meson.build
+++ b/meson.build
@@ -1400,12 +1400,14 @@ if with_platform_x11
dep_xshmfence = dependency('xshmfence', version : '>= 1.1')
endif
endif
- if with_glx == 'dri'
+ if with_glx == 'dri' or with_glx == 'gallium-xlib'
+ dep_glproto = dependency('glproto', version : '>= 1.4.14')
+ endif
+ if with_glx == 'dri'
if with_dri_platform == 'drm'
dep_dri2proto = dependency('dri2proto', version : '>= 2.8')
dep_xxf86vm = dependency('xxf86vm')
endif
- dep_glproto = dependency('glproto', version : '>= 1.4.14')
endif
if (with_egl or (
with_gallium_vdpau or with_gallium_xvmc or with_gallium_xa or