summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorGreg V <[email protected]>2018-01-24 21:02:42 +0300
committerDylan Baker <[email protected]>2018-01-24 15:25:54 -0800
commit53f9131205a63fa8b282ab2a7e96c48209447da0 (patch)
treea843a968aba6ce06d026cc65124733946e051815 /meson.build
parentc38c60a63c63b02d1030c6c349aa0a73105e10eb (diff)
meson: fix getting cflags from pkg-config
get_pkgconfig_variable('cflags') always returns an empty list, it's a function for getting *custom* variables. Meson does not yet support asking for cflags, so explicitly invoke pkg-config for now. Fixes: 68076b87474e ("meson: build gallium vdpau state tracker") Fixes: a817af8a89eb ("meson: build gallium xvmc state tracker") Fixes: 1d36dc674d52 ("meson: build gallium omx state tracker") Fixes: 5a785d51a6d6 ("meson: build gallium va state tracker") Reviewed-by: Dylan Baker <[email protected]>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build10
1 files changed, 6 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index c3a5bbf97f9..56ff916c4bd 100644
--- a/meson.build
+++ b/meson.build
@@ -373,6 +373,8 @@ if with_dri or with_gallium
endif
endif
+prog_pkgconfig = find_program('pkg-config')
+
dep_vdpau = []
_vdpau = get_option('gallium-vdpau')
if _vdpau == 'auto'
@@ -404,7 +406,7 @@ else
endif
if with_gallium_vdpau
dep_vdpau = declare_dependency(
- compile_args : dep_vdpau.get_pkgconfig_variable('cflags').split()
+ compile_args : run_command(prog_pkgconfig, ['vdpau', '--cflags']).stdout().split()
)
endif
@@ -445,7 +447,7 @@ else
endif
if with_gallium_xvmc
dep_xvmc = declare_dependency(
- compile_args : dep_xvmc.get_pkgconfig_variable('cflags').split()
+ compile_args : run_command(prog_pkgconfig, ['xvmc', '--cflags']).stdout().split()
)
endif
@@ -508,7 +510,7 @@ if with_gallium_omx
endif
if with_gallium_omx
dep_omx = declare_dependency(
- compile_args : dep_omx.get_pkgconfig_variable('cflags').split()
+ compile_args : run_command(prog_pkgconfig, ['libomxil-bellagio', '--cflags']).stdout().split()
)
endif
@@ -541,7 +543,7 @@ else
endif
if with_gallium_va
dep_va = declare_dependency(
- compile_args : dep_va.get_pkgconfig_variable('cflags').split()
+ compile_args : run_command(prog_pkgconfig, ['libva', '--cflags']).stdout().split()
)
endif