summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorRob Clark <robdclark@gmail.com>2017-10-14 10:08:50 -0400
committerRob Clark <robdclark@gmail.com>2017-10-24 15:33:40 -0400
commit4aa69cc4257d1f60a1a4cee142fa55e577093407 (patch)
tree36b021475c805bf73edd74a5e8275699e6931361 /meson.build
parent2207af032b0b7326341e974f3b2e0b802e231fa0 (diff)
meson: build freedreno
Mostly copy/pasta from Dylan Baker's conversion of nouveau and i965. Signed-off-by: Rob Clark <robdclark@gmail.com> Reviewed-by: Eric Engestrom <eric.engestrom@imgtec.com> Reviewed-by: Dylan Baker <dylan@pnwbakers.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 9f481225823..8db4699ec5c 100644
--- a/meson.build
+++ b/meson.build
@@ -94,6 +94,7 @@ with_gallium = false
with_gallium_pl111 = false
with_gallium_radeonsi = false
with_gallium_nouveau = false
+with_gallium_freedreno = false
with_gallium_softpipe = false
with_gallium_vc4 = false
with_gallium_vc5 = false
@@ -105,6 +106,7 @@ if _drivers != ''
with_gallium_pl111 = _split.contains('pl111')
with_gallium_radeonsi = _split.contains('radeonsi')
with_gallium_nouveau = _split.contains('nouveau')
+ with_gallium_freedreno = _split.contains('freedreno')
with_gallium_softpipe = _split.contains('swrast')
with_gallium_vc4 = _split.contains('vc4')
with_gallium_vc5 = _split.contains('vc5')
@@ -614,6 +616,7 @@ dep_libdrm_amdgpu = []
dep_libdrm_radeon = []
dep_libdrm_nouveau = []
dep_libdrm_etnaviv = []
+dep_libdrm_freedreno = []
if with_amd_vk or with_gallium_radeonsi
dep_libdrm_amdgpu = dependency('libdrm_amdgpu', version : '>= 2.4.85')
endif
@@ -626,6 +629,9 @@ endif
if with_gallium_etnaviv
dep_libdrm_etnaviv = dependency('libdrm_etnaviv', version : '>= 2.4.82')
endif
+if with_gallium_freedreno
+ dep_libdrm_freedreno = dependency('libdrm_freedreno', version : '>= 2.4.74')
+endif
llvm_modules = ['bitwriter', 'engine', 'mcdisassembler', 'mcjit']
if with_amd_vk