summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorJory Pratt <[email protected]>2019-05-07 21:47:40 -0500
committerJuan A. Suarez Romero <[email protected]>2019-07-02 09:57:34 +0200
commit3d0e6d3cff657923889422d53e24bee70daa74d1 (patch)
tree67e33fa2543970ffb40340354ef8099898e2f781 /meson.build
parent6dca27fce6637e7212fc18937b5e6d25c60c8ca2 (diff)
meson: Search for execinfo.h
Rather than checking __GLIBC__/__UCLIBC__ macros as a proxy for execinfo.h presence, just check directly. This allows the build to work on musl. Reviewed-by: Matt Turner <[email protected]> Reviewed-by: Eric Anholt <[email protected]> Reviewed-by: Eric Engestrom <[email protected]> (cherry picked from commit 10e8d466011076a0453368cb976d9f6b06af0e94)
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 89cb774aa04..a20ada0117a 100644
--- a/meson.build
+++ b/meson.build
@@ -1040,7 +1040,7 @@ elif cc.has_header_symbol('sys/mkdev.h', 'major')
pre_args += '-DMAJOR_IN_MKDEV'
endif
-foreach h : ['xlocale.h', 'sys/sysctl.h', 'linux/futex.h', 'endian.h', 'dlfcn.h']
+foreach h : ['xlocale.h', 'sys/sysctl.h', 'linux/futex.h', 'endian.h', 'dlfcn.h', 'execinfo.h']
if cc.compiles('#include <@0@>'.format(h), name : '@0@'.format(h))
pre_args += '-DHAVE_@0@'.format(h.to_upper().underscorify())
endif