summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDylan Baker <[email protected]>2017-10-04 11:36:06 -0700
committerDylan Baker <[email protected]>2017-10-09 13:42:43 -0700
commit97aea7d5078b8b106178186a789e8516edbc8835 (patch)
tree5b9c453fb7d2e36133c6a41dfb4038f85450006d /meson.build
parent001b65a899af86a5ae18e4558d2978926aff432b (diff)
meson: only require libelf if building radv
And add a todo about clover, r600, and radeonsi, which also need libelf. Signed-off-by: Dylan Baker <[email protected]> Reviewed-by: Eric Anholt <[email protected]>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 5de64acefd6..97809e98289 100644
--- a/meson.build
+++ b/meson.build
@@ -288,7 +288,7 @@ dep_thread = dependency('threads')
pre_args += '-DHAVE_PTHREAD'
dep_elf = dependency('libelf', required : false)
if not dep_elf.found()
- dep_elf = cc.find_library('elf')
+ dep_elf = cc.find_library('elf', required : with_amd_vk) # TODO: clover, r600, radeonsi
endif
dep_expat = dependency('expat')
# this only exists on linux so either this is linux and it will be found, or