summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDylan Baker <[email protected]>2019-01-15 11:55:36 -0800
committerDylan Baker <[email protected]>2019-01-16 17:49:51 +0000
commit431e9abaaba6386aa7fbc1ec0e2566a3f8999f5d (patch)
treeb23b3f997b7d6927708381e773aa2b7c83f9c850 /meson.build
parented7673afd2d1a31bfcec0520743acd2681b462e6 (diff)
meson: allow building dri driver without window system if osmesa is classic
This was already enabled for gallium based osmesa with gallium drivers in 9d10581897ef7cfa0f6c392e2048cc04357281b9, so do the same for classic driver with classic osmesa. Fixes: cbbd5bb889a2c271a504c379f36a7cb717a85af4 ("meson: build classic osmesa") Reviewed-by: Jordan Justen <[email protected]>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index e759bbf96a5..c5bc94720d6 100644
--- a/meson.build
+++ b/meson.build
@@ -382,8 +382,8 @@ if with_any_vk and (with_platform_x11 and not with_dri3)
error('Vulkan drivers require dri3 for X11 support')
endif
if with_dri
- if with_glx == 'disabled' and not with_egl and not with_gbm
- error('building dri drivers require at least one windowing system')
+ if with_glx == 'disabled' and not with_egl and not with_gbm and with_osmesa != 'classic'
+ error('building dri drivers require at least one windowing system or classic osmesa')
endif
endif