aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorErik Faye-Lund <[email protected]>2020-04-15 23:22:51 +0200
committerMarge Bot <[email protected]>2020-04-16 14:48:40 +0000
commitdaeff19608e8ef1937167ffa8b086bba5eb3f60e (patch)
tree2c4824c166317f97fb9b7febd75db465fec09e99 /meson.build
parent0752648a993c6f0fae2f4a072079000b9d84d074 (diff)
meson: tell flex that we support c99
flexint.h uses stdint.h if the compiler claims to support C99. MSVC doesn't support enough of C99 to enable this flag, but it supports enough to keep flex happy. Without this, we end up with *both* some flex-specific definitions as well as our own definitions from mesa-headers, producing a slew of compiler warnings. Reviewed-by: Brian Paul <[email protected]> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/4577>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 6b85c9540e8..9184b69ea8a 100644
--- a/meson.build
+++ b/meson.build
@@ -1506,7 +1506,7 @@ if host_machine.system() == 'windows'
if prog_flex.found()
# windows compatibility (uses <io.h> instead of <unistd.h> and _isatty,
# _fileno functions)
- prog_flex = [prog_flex, '--wincompat']
+ prog_flex = [prog_flex, '--wincompat', '-D__STDC_VERSION__=199901']
else
prog_flex = [find_program('lex', 'flex', required : with_any_opengl)]
endif