aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDylan Baker <[email protected]>2017-10-20 15:57:15 -0700
committerDylan Baker <[email protected]>2017-10-23 11:45:55 -0700
commitd4567efa5ca5383fd5576b8871b3abc05e085360 (patch)
tree075c82bd1bb695392d2985a4426396796940eb31 /meson.build
parent51558a1d6ca43b201362b3b64c751cfc93584346 (diff)
meson: build imx driver
Signed-off-by: Dylan Baker <[email protected]> Reviewed-by: Christian Gmeiner <[email protected]>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 5 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index a21781f3b8c..9f481225823 100644
--- a/meson.build
+++ b/meson.build
@@ -98,6 +98,7 @@ with_gallium_softpipe = false
with_gallium_vc4 = false
with_gallium_vc5 = false
with_gallium_etnaviv = false
+with_gallium_imx = false
_drivers = get_option('gallium-drivers')
if _drivers != ''
_split = _drivers.split(',')
@@ -108,6 +109,7 @@ if _drivers != ''
with_gallium_vc4 = _split.contains('vc4')
with_gallium_vc5 = _split.contains('vc5')
with_gallium_etnaviv = _split.contains('etnaviv')
+ with_gallium_imx = _split.contains('imx')
with_gallium = true
with_dri = true
endif
@@ -123,6 +125,9 @@ endif
if with_dri_swrast and with_gallium_softpipe
error('Only one swrast provider can be built')
endif
+if with_gallium_imx and not with_gallium_etnaviv
+ error('IMX driver requires etnaviv driver')
+endif
dep_libdrm_intel = []
if with_dri_i915