aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDominik Behr <[email protected]>2019-10-21 18:13:08 -0700
committerMarge Bot <[email protected]>2020-04-07 23:15:11 +0000
commitc682ea598f72ded39903015ec3188969fe468ff7 (patch)
tree716727c31bb59aa730efe35cd7718844f2949fce /meson.build
parent940ed5078da594623639580eebefaf75d6ddad4b (diff)
meson: fix debug build on Android
debug_stack functions are implemented in another file for Android. Also add backtrace library dependency. Reviewed-by: Chia-I Wu <[email protected]> Reviewed-bu: Kristian H. Kristensen <[email protected]> Signed-off-by: Dominik Behr <[email protected]> Acked-by: Dylan Baker <[email protected]> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/2435>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 86824bd8e8b..cb275e7dcc1 100644
--- a/meson.build
+++ b/meson.build
@@ -786,6 +786,9 @@ if with_platform_android
dependency('hardware'),
dependency('sync'),
]
+ if with_gallium
+ dep_android += dependency('backtrace')
+ endif
if get_option('platform-sdk-version') >= 26
dep_android += dependency('nativewindow')
endif