summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorKonstantin Kharlamov <[email protected]>2019-02-03 21:36:32 +0300
committerEric Engestrom <[email protected]>2019-02-13 14:20:51 +0000
commitfccc9d3de6cfd1f4d7dbf49af1582b88d143c4cd (patch)
tree7f58dffc5e63e3d49a689de22a9b901fc71bd638 /meson.build
parent017349997fd3e194ab3e598712a66c04be5a60ad (diff)
mapi: work around GCC LTO dropping assembly-defined functions
Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=109391 Signed-off-by: Konstantin Kharlamov <[email protected]> Acked-by: Eric Engestrom <[email protected]> Reviewed-by: Dylan Baker <[email protected]> Reviewed-by: Eric Engestrom <[email protected]>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 8c24ef268f3..fbc02970e68 100644
--- a/meson.build
+++ b/meson.build
@@ -1465,6 +1465,10 @@ pkg = import('pkgconfig')
env_test = environment()
env_test.set('NM', find_program('nm').path())
+# This quirk needs to be applied to sources with functions defined in assembly
+# as GCC LTO drops them. See: https://bugs.freedesktop.org/show_bug.cgi?id=109391
+gcc_lto_quirk = (cc.get_id() == 'gcc') ? ['-fno-lto'] : []
+
subdir('include')
subdir('bin')
subdir('src')