summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorJonathan Marek <[email protected]>2019-01-27 21:05:33 -0500
committerRob Clark <[email protected]>2019-01-28 18:25:27 -0500
commitf6292c32cc7ace408cb9016806ebf1d9a387bcf8 (patch)
tree5437aace67f5bee5387bdfeed8948b5b373a97ee /meson.build
parent7d458c0c69ad80e3d01c0ba79e57ed3981764823 (diff)
kmsro: Add freedreno renderonly support
Signed-off-by: Jonathan Marek <[email protected]>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 4a81cd05532..d975b0dbf4b 100644
--- a/meson.build
+++ b/meson.build
@@ -209,8 +209,8 @@ endif
if with_dri_i915 and with_gallium_i915
error('Only one i915 provider can be built')
endif
-if with_gallium_kmsro and not (with_gallium_vc4 or with_gallium_etnaviv)
- error('kmsro driver requires one or more renderonly drivers (vc4, etnaviv)')
+if with_gallium_kmsro and not (with_gallium_vc4 or with_gallium_etnaviv or with_gallium_freedreno)
+ error('kmsro driver requires one or more renderonly drivers (vc4, etnaviv, freedreno)')
endif
if with_gallium_tegra and not with_gallium_nouveau
error('tegra driver requires nouveau driver')