summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorEric Engestrom <[email protected]>2018-11-20 12:32:18 +0000
committerEric Engestrom <[email protected]>2019-03-08 16:24:06 +0000
commite1d81decf7a093867f051786a5d7f6ce4d827ff1 (patch)
tree0164b600998902f27e0d98a4cb9880a8bb5f87d8 /meson.build
parent598f10eacca1488e580779fc9b6110ed9cba1f13 (diff)
build: make passing an incorrect pointer type a hard error
More or less any of this issue pointed out by the compiler is a coding error. Make sure we flag it and bail loudly. v2: - apply the change to autotools and scons as well (Emil) - C++ doesn't need this, it's already an error and the flag doesn't exist (Gert) v3: - drop scons, flags are not checked so until someone adds that functionality we can't have this. Signed-off-by: Eric Engestrom <[email protected]> Reviewed-by: Dylan Baker <[email protected]> # v1 Reviewed-by: Emil Velikov <[email protected]> # v1 [Emil: apply the same change to autotools and scons] Signed-off-by: Emil Velikov <[email protected]> Reviewed-by: Eric Anholt <[email protected]>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 8a40c48e435..2ccf5f2a4ca 100644
--- a/meson.build
+++ b/meson.build
@@ -804,6 +804,7 @@ endif
c_args = []
foreach a : ['-Werror=implicit-function-declaration',
'-Werror=missing-prototypes', '-Werror=return-type',
+ '-Werror=incompatible-pointer-types',
'-fno-math-errno',
'-fno-trapping-math', '-Qunused-arguments']
if cc.has_argument(a)